Marketing website

Incident Report for Postman

Resolved

DNS corrected. Engineers analyzing / auditing change events.
Posted Jul 22, 2026 - 10:12 PDT

Identified

DNS issues found. Working on resolution
Posted Jul 22, 2026 - 09:51 PDT

Investigating

We are aware of marketing website outage and engineers are investigating
Posted Jul 22, 2026 - 09:42 PDT
This incident affected: US (Postman Platform on Browser, Postman Login, Marketing Website) and Europe (Postman Login).