Collections and Environments view scenarios are degraded

Incident Report for Postman

Resolved

We have monitored stats and service has been stable.
Posted Jul 17, 2026 - 07:50 PDT

Monitoring

A fix has been deployed and we are monitoring the health of the service
Posted Jul 17, 2026 - 06:35 PDT

Identified

The team has identified an issue with the service probe endpoint and deploying a fix.
Posted Jul 17, 2026 - 06:32 PDT

Investigating

Collections fetch flows are facing failures and increased latencies. Team is investigating the issue
Posted Jul 17, 2026 - 05:33 PDT
This incident affected: US (Postman Platform on Desktop, Postman Platform on Browser).