Postman Workspaces are not Loading

Incident Report for Postman

Resolved

All our systems are back to normal
Posted May 07, 2025 - 12:19 UTC

Monitoring

Our systems are recovering and we are continuously monitoring
Posted May 07, 2025 - 12:09 UTC

Identified

We have identified the issue and our systems are in recovering phase at the moment.
Posted May 07, 2025 - 11:47 UTC

Investigating

We are currently investigating the issue
Posted May 07, 2025 - 11:17 UTC
This incident affected: US (Postman Platform on Desktop, Postman Platform on Browser).