Issue launching the Postman App for Windows and Linux users (released today, March 17)
Incident Report for Postman
Resolved
We believe the issue has been resolved based on our telemetry data and affirmative user feedback.

In Summary, at 18:15 UTC, we released the Postman Desktop app v9.15.1. We immediately discovered that the version had an issue that resulted in Windows and Linux users not being able to launch the app. The app would stay stuck at a perpetual white screen. The issue was mitigated at 19:30 UTC, and a patch was subsequently released.

If you are on Postman v9.15.1 and experiencing this issue, the latest Postman app, with the patch for this issue, is available for download from https://www.postman.com/downloads.

If you are on the Postman app version 9.15.2 or above, you already have the app version that has the patch. You can click on the settings icon on the top right corner of the Postman and head on to the "About" section to check your current Postman App version.

Additionally, here's the link to our support thread with additional discussions around this issue - https://github.com/postmanlabs/postman-app-support/issues/10763

Your data within Postman and your local data in the scratch pad are safe. We apologize for the inconvenience caused.
Posted Mar 18, 2022 - 01:57 UTC
Monitoring
The issue has been resolved and released for general availability. We are continuing to monitor reports from users. If you are affected, you can download the latest version of the app from https://www.postman.com/downloads
Posted Mar 18, 2022 - 00:14 UTC
Update
We have resolved the issue internally and are executing our pre release checks and checklists. We will update this space once the patch is out the door. Meanwhile, if you are affected and are seeing a blank white screen when launching the app, you can downgrade to the latest working version from https://www.postman.com/downloads
Posted Mar 17, 2022 - 23:10 UTC
Identified
We have identified an issue with our latest (v9.15.1) release of the Postman App affecting Windows and Linux users. For the affected users, the app would refuse to start and remain stuck at a white screen. We are working towards releasing a patch for the same in a very short while. We will keep you posted. If you are affected, you can downgrade to the latest known working version from https://www.postman.com/downloads
Posted Mar 17, 2022 - 22:06 UTC
This incident affected: Postman Platform on Desktop.