Postman network issues in EU

Incident Report for Postman

Resolved

Reverting the maintenance operation has resolved the connectivity issues.
Posted Nov 20, 2025 - 09:18 PST

Monitoring

Network changes have been reverted and services are restored
Posted Nov 20, 2025 - 09:10 PST

Identified

The issue has been identified and a fix is being implemented.
Posted Nov 20, 2025 - 08:41 PST

Investigating

Postman engineers have identified a networking issue in our EU environment
Posted Nov 20, 2025 - 08:40 PST
This incident affected: Europe (Postman Platform on Desktop, Postman Platform on Browser, Postman Login).