Syncing issue for a subset of Postman Desktop app v7.25.1 users using NTLM proxy
Incident Report for Postman
Resolved
This issue is resolved and Postman v7.26.1 is able to connect to Postman's syncing services behind an NTLM proxy.
Posted Jun 19, 2020 - 05:30 UTC
Monitoring
Postman v7.26.1 is available now with this fix and we are working with impacted teams and users for confirmation.
Posted Jun 18, 2020 - 09:43 UTC
Update
We have confirmed reports from the majority of affected teams that the fix in v7.27.0-canary07 is working reliably with their proxies. We are preparing a patch version (v7.26.1) for our stable app and this version is expected to start rolling out today.
Posted Jun 18, 2020 - 07:25 UTC
Update
We have identified a more reliable fix to resolve the NTLM handshake issue while establishing a WebSocket connection via a proxy. This fix is available on our early-access Canary channel (v7.27.0-canary07) and we are working with affected teams to verify the fix.

If you are impacted by this issue, do try this Canary build (https://www.postman.com/downloads/canary/) and let us know via help@postman.com.
Posted Jun 17, 2020 - 19:19 UTC
Update
We have confirmation from few impacted users that the preliminary fix in our Canary build "v7.27.0-canary06" does not completely resolve this and the issue still persists in these environments.

We are still working on mitigating this issue and if you are impacted by this issue, let us know via help@postman.com.
Posted Jun 17, 2020 - 09:37 UTC
Update
We are still working to mitigate this issue and have workaround procedures ready for impacted users. If you’re impacted by this issue, please reach out to help@postman.com.

Meanwhile, we haven’t received any additional report from users and have definitely isolated the impact to be limited within NTLM proxy users. General usage of the app around request sending should not be impacted by this. Once the issue is resolved, upgrading the app would automatically synchronise your work done during this period. As such, we are reclassifying the impact as minor.
Posted Jun 16, 2020 - 23:15 UTC
Identified
We have identified that the Postman Desktop App is not completing NTLM handshake with certain proxies, while performing a WebSocket connection. We've released a preliminary fix on our early-access Canary channel and is working with affected teams to verify the fix.

If you are impacted by this issue, do try out the latest Canary build (https://www.postman.com/downloads/canary/) and let us know via help@postman.com if the issue is resolved in your environment.
Posted Jun 16, 2020 - 18:29 UTC
Investigating
A small percentage of users using Postman Desktop app v7.25.1 and above are reporting data syncing issues while using the app. This is reported to be occurring only if the network environment uses NTLM proxy to connect to Postman servers.

We are currently investigating this issue.
Posted Jun 16, 2020 - 16:09 UTC
This incident affected: Postman App.