Postman Collections not working in EU region

Incident Report for Postman

Resolved

Collections in EU are fully working now.
Posted Feb 20, 2026 - 05:13 PST

Update

Collection operations are recovering now.
Posted Feb 20, 2026 - 05:04 PST

Monitoring

Collection operations in Europe are not working. We are working on resolving this.
Posted Feb 20, 2026 - 04:59 PST
This incident affected: Europe (Postman API).